Tuesday, 27 February 2018

Element.MoveByVector

Element.MoveByVector

Most of the time I like to write about something that I got to work. This time it's slightly different. So far I don't get this thing to work. I am looking into this node called move by vector. It allows for moving elements in Revit by a vector. The vector can be created using two points. I wanted to experiment with this node after a tweet from Luke Johnson about shared coordinates. we need to change Shared Coordinates.

the reason for wanting to move all these elements is to see if I could fix a file whose shared coordinates have been set up incorrectly. Why do I want to fix a file when there are OTB functionalities for  making things appear they are in the right location? Well, I just want to know what is possible.

I wanted to test to see if I could move all the elements in a file to a new location. A small test on furniture worked just fine. But that are simple point families. I got walls to move as well which is nice as these are line based families. But then the real test came let's try ducts....
So far the only thing I got is a complete mess. I tried to move all the elements that are connected to ducts. The flex ducts do not seem to want to behave. The ducts them self also seem to take directions into their own hand. See below.


The duct fittings don't want to go either. I suspect that it has to do in the order that things get moved. Now I am moving stuff per category. Let's try to move elements per system. Or maybe I am simply expecting to much of this node and is the translation of elements rather complicated.

the script so far that does not want to work.


Let's try one system at the time. The system I want to move is coloured red. To ease selection I use the select model elements node to select all the elements from the same system.

After the translation, and 23 errors I got this. It's seems to me to me that this Element.MoveByVector moves one element at the time and in between tries to maintain all kind of constraints which it obviously can't do.
So far no luck. I'll have a chat with some colleagues first and see if it is possible.




Google+ Badge